<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://aarn.com/xmlrpc.php" />
<title>Feature Winners: February 20 &#8211; 26, 2018 &#8211; The Official Site of Area Auto Racing News and Len Sammons Productions</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Official Site of Area Auto Racing News and Len Sammons Productions &raquo; Feed" href="http://aarn.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Official Site of Area Auto Racing News and Len Sammons Productions &raquo; Comments Feed" href="http://aarn.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/aarn.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://aarn.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='http://aarn.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='http://aarn.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='http://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='upw_theme_standard-css'  href='http://aarn.com/wp-content/plugins/ultimate-posts-widget/css/upw-theme-standard.min.css' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='easy_table_style-css'  href='http://aarn.com/wp-content/plugins/easy-table/themes/cuscosky/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://aarn.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='zfp_style-css'  href='http://aarn.com/wp-content/plugins/zenfoliopress/zfp.css' type='text/css' media='all' />
<link rel='stylesheet' id='zfp_slimbox2-css'  href='http://aarn.com/wp-content/plugins/zenfoliopress/slimbox2.css' type='text/css' media='all' />
<script type='text/javascript' src='http://aarn.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://aarn.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://aarn.com/wp-content/plugins/zenfoliopress/slimbox2.js'></script>
<link rel='https://api.w.org/' href='http://aarn.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://aarn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://aarn.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Newsmaker of the Week // Tim McCreadie' href='http://aarn.com/2018/02/19/newsmaker-of-the-week-tim-mccreadie/' />
<meta name="generator" content="WordPress 4.8.5" />
<link rel="canonical" href="http://aarn.com/2018/02/25/feature-winners-february-20-26-2018/" />
<link rel='shortlink' href='http://wp.me/p4LVI9-2BB' />
<link rel="alternate" type="application/json+oembed" href="http://aarn.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Faarn.com%2F2018%2F02%2F25%2Ffeature-winners-february-20-26-2018%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://aarn.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Faarn.com%2F2018%2F02%2F25%2Ffeature-winners-february-20-26-2018%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel="shortcut icon" href="http://03a4cfb.netsolhost.com/WordPress/wp-content/uploads/2014/12/aarnfavicon.png" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="http://aarn.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="http://aarn.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="http://aarn.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://aarn.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="http://aarn.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<link href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '206255333205885', {
em: 'insert_email_variable'
});
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=206255333205885&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->



<style type="text/css" media="screen">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</style>

<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://aarn.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Feature Winners: February 20 &#8211; 26, 2018" />
<meta property="og:url" content="http://aarn.com/2018/02/25/feature-winners-february-20-26-2018/" />
<meta property="og:description" content="Visit the post for more." />
<meta property="article:published_time" content="2018-02-25T17:48:49+00:00" />
<meta property="article:modified_time" content="2018-02-26T14:19:23+00:00" />
<meta property="og:site_name" content="The Official Site of Area Auto Racing News and Len Sammons Productions" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Visit the post for more." />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body id="top" class="post-template-default single single-post postid-10019 single-format-standard lazy-enabled wpb-js-composer js-comp-ver-5.0.1 vc_responsive">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

	
	
		<div id="mobile-menu"  class="mobile-hide-icons"></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed-all">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header full-logo center-logo">
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="The Official Site of Area Auto Racing News and Len Sammons Productions" href="http://aarn.com/">
					<img src="http://aarn.com/wp-content/uploads/2015/10/main_page_logo2016.jpg" alt="The Official Site of Area Auto Racing News and Len Sammons Productions"  /><strong>The Official Site of Area Auto Racing News and Len Sammons Productions Area Auto Racing News</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-402"><a href="http://aarn.com">Home</a></li>
<li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="http://www.aarn.com/index.php">Area Auto Racing News</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-165" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-165"><a href="http://aarn.com/category/feature-winners/">Feature Winners</a></li>
	<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169"><a href="http://aarn.com/category/newsmaker-of-the-week/">Newsmaker of the Week</a></li>
	<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168"><a href="http://aarn.com/category/from-the-paper/">From the Paper</a></li>
	<li id="menu-item-401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-401"><a href="http://aarn.com/category/this-week-in-aarn/">This Week in AARN</a></li>
	<li id="menu-item-452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-452"><a href="http://aarn.com/congratulations-personal-message-ads/">Congratulations &#038; Personal Message Ads</a></li>
	<li id="menu-item-219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219"><a href="http://aarn.com/advertise-with-us/">Advertise</a></li>
	<li id="menu-item-400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-400"><a href="http://aarn.com/category/trivia-photo/">Trivia Photo</a></li>
	<li id="menu-item-223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-223"><a href="http://aarn.com/submit-change-of-address/">Submit Change of Address</a></li>
	<li id="menu-item-8131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8131"><a href="http://aarn.com/contact/">Contact</a></li>
</ul>
</li>
<li id="menu-item-8979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8979"><a href="http://areaautoracingnews.zenfolio.com/">Photos</a></li>
<li id="menu-item-8135" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8135 mega-menu mega-recent-featured "><a href="http://aarn.com/category/feature-winners/">Feature Winners</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/25/feature-winners-february-20-26-2018/" title="Feature Winners: February 20 &#8211; 26, 2018">Feature Winners: February 20 &#8211; 26, 2018</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>February 25, 2018</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/14/feature-winner-february-13-19-2018/" title="Feature Winner: February 13 &#8211; 19, 2018">Feature Winner: February 13 &#8211; 19, 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>February 14, 2018</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/07/feature-winners-february-6-12-2018/" title="Feature Winners: February 6 &#8211; 12, 2018">Feature Winners: February 6 &#8211; 12, 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>February 7, 2018</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/01/feature-winners-january-30-february-5-2018/" title="Feature Winners: January 30 &#8211; February 5, 2018">Feature Winners: January 30 &#8211; February 5, 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>February 1, 2018</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/01/18/feature-winners-january-16-22-2018/" title="Feature Winners: January 16 &#8211; 22, 2018">Feature Winners: January 16 &#8211; 22, 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 18, 2018</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/01/17/feature-winners-january-16-22-2018-2/" title="Feature Winners: January 23 &#8211; 29, 2018">Feature Winners: January 23 &#8211; 29, 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 17, 2018</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/01/11/feature-winners-january-9-15-2018/" title="Feature Winners: January 9 &#8211; 15, 2018">Feature Winners: January 9 &#8211; 15, 2018</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>January 11, 2018</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-8133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8133 mega-menu mega-cat "><a href="http://aarn.com/category/newsmaker-of-the-week/">Newsmaker</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-8133-4" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2018/02/19/newsmaker-of-the-week-tim-mccreadie/" title="Newsmaker of the Week // Tim McCreadie"><img src="http://aarn.com/wp-content/uploads/2018/02/NEWSMAKER-1-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Tim McCreadie" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/19/newsmaker-of-the-week-tim-mccreadie/" title="Newsmaker of the Week // Tim McCreadie">Newsmaker of the Week // Tim McCreadie</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>February 19, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2018/02/12/newsmaker-of-the-week-donny-schatz-4/" title="Newsmaker of the Week // Donny Schatz"><img src="http://aarn.com/wp-content/uploads/2018/02/NEWSMAKER-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Donny Schatz" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/12/newsmaker-of-the-week-donny-schatz-4/" title="Newsmaker of the Week // Donny Schatz">Newsmaker of the Week // Donny Schatz</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>February 12, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2018/02/05/newsmaker-of-the-week-josh-richards/" title="Newsmaker of the Week // Josh Richards"><img src="http://aarn.com/wp-content/uploads/2018/02/NEWSMAKER-310x165.png" width="310" height="165" alt="Newsmaker of the Week // Josh Richards" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/02/05/newsmaker-of-the-week-josh-richards/" title="Newsmaker of the Week // Josh Richards">Newsmaker of the Week // Josh Richards</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>February 5, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2018/01/22/newsmaker-of-the-week-ppb-motorsports-racecar-trade-show/" title="Newsmaker of the Week // PPB Motorsports Racecar &#038; Trade Show"><img src="http://aarn.com/wp-content/uploads/2018/01/NEWSMAKER-310x165.png" width="310" height="165" alt="Newsmaker of the Week // PPB Motorsports Racecar &#038; Trade Show" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/01/22/newsmaker-of-the-week-ppb-motorsports-racecar-trade-show/" title="Newsmaker of the Week // PPB Motorsports Racecar &#038; Trade Show">Newsmaker of the Week // PPB Motorsports Racecar &#038; Trade Show</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>January 22, 2018</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content -->
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-8134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8134 mega-menu mega-cat "><a href="http://aarn.com/category/from-the-paper/">From the Paper</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-8134-8" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2018/01/29/memorial-service-details-from-the-krause-family/" title="MEMORIAL SERVICE DETAILS FROM THE KRAUSE FAMILY"><img src="http://aarn.com/wp-content/uploads/2018/01/NEWSMAKER-2-310x165.jpg" width="310" height="165" alt="MEMORIAL SERVICE DETAILS FROM THE KRAUSE FAMILY" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2018/01/29/memorial-service-details-from-the-krause-family/" title="MEMORIAL SERVICE DETAILS FROM THE KRAUSE FAMILY">MEMORIAL SERVICE DETAILS FROM THE KRAUSE FAMILY</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>January 29, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2017/12/28/cliff-diane-krause-sign-lease-to-operate-njs-wall-stadium-for-2018-and-19/" title="Cliff &#038; Diane Krause Sign Lease To Operate NJ’s Wall Stadium For 2018 and 19"><img src="http://aarn.com/wp-content/uploads/2017/12/On-AARN-Now-310x165.jpg" width="310" height="165" alt="Cliff &#038; Diane Krause Sign Lease To Operate NJ’s Wall Stadium For 2018 and 19" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2017/12/28/cliff-diane-krause-sign-lease-to-operate-njs-wall-stadium-for-2018-and-19/" title="Cliff &#038; Diane Krause Sign Lease To Operate NJ’s Wall Stadium For 2018 and 19">Cliff &#038; Diane Krause Sign Lease To Operate NJ’s Wall Stadium For 2018 and 19</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>December 28, 2017</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2017/08/31/ninth-year-at-woodhulls-helm-owner-ted-white-has-a-good-thing-going/" title="Ninth Year At Woodhull’s Helm, Owner Ted White Has A Good Thing Going"><img src="http://aarn.com/wp-content/uploads/2017/08/On-AARN-Now-1-310x165.jpg" width="310" height="165" alt="Ninth Year At Woodhull’s Helm, Owner Ted White Has A Good Thing Going" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2017/08/31/ninth-year-at-woodhulls-helm-owner-ted-white-has-a-good-thing-going/" title="Ninth Year At Woodhull’s Helm, Owner Ted White Has A Good Thing Going">Ninth Year At Woodhull’s Helm, Owner Ted White Has A Good Thing Going</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>August 31, 2017</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="http://aarn.com/2017/08/10/brett-hearns-incredible-march-to-900-career-feature-event-wins/" title="Brett Hearn’s Incredible March To 900 Career Feature Event Wins"><img src="http://aarn.com/wp-content/uploads/2017/08/On-AARN-Now-310x165.jpg" width="310" height="165" alt="Brett Hearn’s Incredible March To 900 Career Feature Event Wins" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="http://aarn.com/2017/08/10/brett-hearns-incredible-march-to-900-career-feature-event-wins/" title="Brett Hearn’s Incredible March To 900 Career Feature Event Wins">Brett Hearn’s Incredible March To 900 Career Feature Event Wins</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>August 10, 2017</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content -->
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-9702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9702"><a href="http://motorsportstradeshow.com/">Motorsports Show</a></li>
<li id="menu-item-7490" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7490"><a target="_blank" href="http://www.indoorautoracing.com">Indoor Racing Series</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-8137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8137"><a href="http://www.indoorautoracing.com/indoor-dirt-nationals/">Trenton Indoor Race</a></li>
	<li id="menu-item-8138" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8138"><a href="http://www.indoorautoracing.com/allentown-event-information/">Allentown Indoor Race</a></li>
	<li id="menu-item-8139" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8139"><a href="http://www.indoorautoracing.com/atlantic-city-event-information/">AC Indoor Race</a></li>
	<li id="menu-item-9958" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9958"><a href="http://www.indoorautoracing.com/albany-event-information/">Albany Indoor Race</a></li>
</ul>
</li>
<li id="menu-item-4189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4189"><a href="http://store.aarn.com">E-Store</a></li>
<li id="menu-item-4567" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4567"><a href="http://aarn.com/adverts-list/">Classifieds</a></li>
<li id="menu-item-8130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8130"><a href="http://aarn.com/contact/">Contact</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container sidebar-left">
	
	
	
	
	
	<div class="content">

		
		
		

		
		<article class="post-listing post-10019 post type-post status-publish format-standard  category-feature-winners" id="the-post">
			
			<div class="single-post-thumb">
					</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Feature Winners: February 20 &#8211; 26, 2018</span></h1>

							
				<div class="entry">
					
					
					<div></div>
<p class="p1"><div class="table-responsive"><table  style="width:100%; "  class="easy-table easy-table-cuscosky " >
<tbody>
<tr><td ><p class="p1">Bubba’s, FL </td>
<td >(Thur., LM)</td>
</tr>

<tr><td ></td>
<td >(Fri., LM)</td>
</tr>

<tr><td ></td>
<td >(Sat., LM)</td>
</tr>

<tr><td >Lincoln, PA </td>
<td >(Sat., &amp</td>
<td > Sun.) RAIN</td>
</tr>

<tr><td >NASCAR: Atlanta, GA</td>
<td >(Cup) KEVIN HARVICK</td>
</tr>

<tr><td ></td>
<td >(Xfinity) KEVIN HARVICK</td>
</tr>

<tr><td ></td>
<td >(Trucks) BRETT MOFFITT</td>
</tr>

<tr><td >NHRA</td>
<td > Chandler, AZ</td>
<td >(Top Fuel)</td>
</tr>

<tr><td ></td>
<td >(Funny Car)</td>
</tr>

<tr><td ></td>
<td >(Pro Stock)</td>
</tr>

<tr><td >PASS South: Dillon, SC</td>
<td >(SLM 200) DEREK GRIFFITH</td>
</tr>

<tr><td >USCS 360 Sprint: </td>
<td >Milton, FL (Fri.)  TERRY GRAY</td>
</tr>

<tr></tr>

<tr><td >World of Outlaw Sprints</td>
<td > Paige, TX (Fri.) WET GROUNDS</td>
</tr>

<tr><td ></td>
<td >Kilgore, TX (Sat.) WET GROUNDS</td>
</tr>

<tr><td ><p class="p1"></td>
</tr>
</tbody></table></div>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2018-02-25T12:48:49+00:00","datePublished":"2018-02-25T12:48:49+00:00","dateModified":"2018-02-26T09:19:23+00:00","headline":"Feature Winners: February 20 &#8211; 26, 2018","name":"Feature Winners: February 20 &#8211; 26, 2018","keywords":[],"url":"http:\/\/aarn.com\/2018\/02\/25\/feature-winners-february-20-26-2018\/","description":"","copyrightYear":"2018","publisher":{"@id":"#Publisher","@type":"Organization","name":"The Official Site of Area Auto Racing News and Len Sammons Productions","logo":{"@type":"ImageObject","url":"http:\/\/aarn.com\/wp-content\/uploads\/2015\/10\/main_page_logo2016.jpg"},"sameAs":["http:\/\/www.facebook.com\/areaautoracingnews","http:\/\/www.twitter.com\/aarn"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/aarn.com\/2018\/02\/25\/feature-winners-february-20-26-2018\/"},"author":{"@type":"Person","name":"Lenny Sammons","url":"http:\/\/aarn.com\/author\/lenny-sammons\/"},"articleSection":"Feature Winners","articleBody":"\r\n"}</script>
		</article><!-- .post-listing -->
		

		<div class="e3lan e3lan-post">
			<a href="http://store.aarn.com" title="" target="_blank"rel="nofollow">
				<img src="http://aarn.com/wp-content/uploads/2015/10/subscribe-2016.jpg" alt="" />
			</a>
				</div>
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<h3><a href="http://aarn.com/2018/02/14/feature-winner-february-13-19-2018/" rel="bookmark">Feature Winner: February 13 &#8211; 19, 2018</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>February 14, 2018</span></p>
			</div>
						<div class="related-item">
							
				<h3><a href="http://aarn.com/2018/02/07/feature-winners-february-6-12-2018/" rel="bookmark">Feature Winners: February 6 &#8211; 12, 2018</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>February 7, 2018</span></p>
			</div>
						<div class="related-item">
							
				<h3><a href="http://aarn.com/2018/02/01/feature-winners-january-30-february-5-2018/" rel="bookmark">Feature Winners: January 30 &#8211; February 5, 2018</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>February 1, 2018</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
		
		
				
<div id="comments">


<div class="clear"></div>


</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
			<div id="text-html-widget-4" class="text-html-box" >
			<div class="widget-container"><a href="http://digital.turn-page.com/t/30678"><img class="alignnone wp-image-373 size-full" src="http://www.aarn.com/wp-content/uploads/2015/09/DIGITAL_EDITION.png" alt="DIGITAL_EDITION" width="288" height="237" /></a>
<h2 style="text-align: left;"><a title="Sign-Up for the Digital Edition of AARN" href="http://aarn.com/?page_id=1376">Click Here to Sign-Up for the Digital Edition of AARN</a></h2><br></div>			</div>
		<div id="login-widget-3" class="widget login-widget"><div class="widget-top"><h4>Classifieds Login</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div id="login-form">
			<form name="loginform" id="loginform" action="http://aarn.com/wp-login.php" method="post">
				<p id="log-username"><input type="text" name="log" id="log" title="Username" value="Username" onfocus="if (this.value == 'Username') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Username';}"  size="33" /></p>
				<p id="log-pass"><input type="password" name="pwd" id="pwd" title="Password" value="Password" onfocus="if (this.value == 'Password') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Password';}" size="33" /></p>
				<input type="submit" name="submit" value="Log in" class="login-button" />
				<label for="rememberme"><input name="rememberme" id="rememberme" type="checkbox" checked="checked" value="forever" /> Remember Me</label>
				<input type="hidden" name="redirect_to" value="/2018/02/25/feature-winners-february-20-26-2018/"/>
			</form>
			<ul class="login-links">
				<li><a href="http://aarn.com/wp-login.php?action=register">Register</a></li>				<li><a href="http://aarn.com/wp-login.php?action=lostpassword&redirect_to=http://aarn.com">Lost your password?</a></li>
			</ul>
		</div>
	</div></div><!-- .widget /--><div id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-top"><h4>Classifieds Toolbox</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="menu-classifieds-container"><ul id="menu-classifieds" class="menu"><li id="menu-item-3734" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3734"><a href="http://aarn.com/adverts-2/add/">Create a New Ad</a></li>
<li id="menu-item-3733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3733"><a href="http://aarn.com/adverts-2/manage/">Manage Your Ad</a></li>
<li id="menu-item-3763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3763"><a href="http://aarn.com/adverts/">Classifieds Main Page</a>
<ul  class="sub-menu">
	<li id="menu-item-3751" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3751"><a href="http://aarn.com/advert-category/collectibles/">Collectibles</a></li>
	<li id="menu-item-3752" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3752"><a href="http://aarn.com/advert-category/help-wanted/">Help Wanted</a></li>
	<li id="menu-item-3753" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3753"><a href="http://aarn.com/advert-category/miscellaneous/">Miscellaneous</a></li>
	<li id="menu-item-3754" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3754"><a href="http://aarn.com/advert-category/parts-engines/">Parts &#038; Engines</a></li>
	<li id="menu-item-3755" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3755"><a href="http://aarn.com/advert-category/race-cars/">Race Cars</a></li>
	<li id="menu-item-3756" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3756"><a href="http://aarn.com/advert-category/ride-wanted/">Ride Wanted</a></li>
	<li id="menu-item-3757" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3757"><a href="http://aarn.com/advert-category/services/">Services</a></li>
	<li id="menu-item-3758" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3758"><a href="http://aarn.com/advert-category/shop-equipment/">Shop Equipment</a></li>
	<li id="menu-item-3759" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3759"><a href="http://aarn.com/advert-category/tickets/">Tickets</a></li>
	<li id="menu-item-3760" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3760"><a href="http://aarn.com/advert-category/tow-vehicles-trailers/">Tow Vehicles &#038; Trailers</a></li>
	<li id="menu-item-3761" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3761"><a href="http://aarn.com/advert-category/videosphotos/">Videos/Photos</a></li>
	<li id="menu-item-3762" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3762"><a href="http://aarn.com/advert-category/wanted/">Wanted</a></li>
</ul>
</li>
</ul></div></div></div><!-- .widget /--><div id="facebook-likebox-3" class="widget widget_facebook_likebox"><div class="widget-top"><h4><a href="https://www.facebook.com/areaautoracingnews">Find Us on Facebook</a></h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/areaautoracingnews" data-width="285"  data-height="700" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/areaautoracingnews"><a href="https://www.facebook.com/areaautoracingnews">Find Us on Facebook</a></blockquote></div>
		</div>
		</div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
					</div>
				
		<div class="alignleft">
					</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
<div id="fb-root"></div>
	<div style="display:none">
	</div>
<div id="reading-position-indicator"></div><script type='text/javascript' src='http://aarn.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://aarn.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://aarn.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='http://aarn.com/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='http://aarn.com/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://aarn.com/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://aarn.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201809.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'70528605',post:'10019',tz:'-5',srv:'aarn.com'} ]);
	_stq.push([ 'clickTrackerInit', '70528605', '10019' ]);
</script>
</body>
</html>