<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://aarn.com/xmlrpc.php" />
<title>Feature Winners: March 27 &#8211; April 2, 2018 &#8211; The Official Site of Area Auto Racing News and Len Sammons Productions</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Official Site of Area Auto Racing News and Len Sammons Productions &raquo; Feed" href="https://aarn.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Official Site of Area Auto Racing News and Len Sammons Productions &raquo; Comments Feed" href="https://aarn.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/aarn.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://aarn.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://aarn.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://aarn.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://aarn.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='upw_theme_standard-css'  href='https://aarn.com/wp-content/plugins/ultimate-posts-widget/css/upw-theme-standard.min.css' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://aarn.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css'  href='https://aarn.com/wp-content/plugins/easy-table/themes/cuscosky/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://aarn.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='zfp_style-css'  href='https://aarn.com/wp-content/plugins/zenfoliopress/zfp.css' type='text/css' media='all' />
<link rel='stylesheet' id='zfp_slimbox2-css'  href='https://aarn.com/wp-content/plugins/zenfoliopress/slimbox2.css' type='text/css' media='all' />
<script type='text/javascript' src='https://aarn.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/zenfoliopress/slimbox2.js'></script>
<link rel='https://api.w.org/' href='https://aarn.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://aarn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://aarn.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='This Week in AARN // March 27, 2018' href='https://aarn.com/2018/03/26/this-week-in-aarn-march-27-2018/' />
<link rel='next' title='Newsmaker of the Week // Brian Montieth' href='https://aarn.com/2018/04/02/newsmaker-of-the-week-brian-montieth/' />
<meta name="generator" content="WordPress 4.9.11" />
<link rel="canonical" href="https://aarn.com/2018/03/28/feature-winners-march-27-april-2-2018/" />
<link rel='shortlink' href='https://wp.me/p4LVI9-2EC' />
<link rel="alternate" type="application/json+oembed" href="https://aarn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Faarn.com%2F2018%2F03%2F28%2Ffeature-winners-march-27-april-2-2018%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://aarn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Faarn.com%2F2018%2F03%2F28%2Ffeature-winners-march-27-april-2-2018%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="shortcut icon" href="http://03a4cfb.netsolhost.com/WordPress/wp-content/uploads/2014/12/aarnfavicon.png" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://aarn.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://aarn.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://aarn.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://aarn.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://aarn.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<link href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '206255333205885', {
em: 'insert_email_variable'
});
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=206255333205885&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->



<style type="text/css" media="screen">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</style>

<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://aarn.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Feature Winners: March 27 &#8211; April 2, 2018" />
<meta property="og:url" content="https://aarn.com/2018/03/28/feature-winners-march-27-april-2-2018/" />
<meta property="og:description" content="Visit the post for more." />
<meta property="article:published_time" content="2018-03-28T16:18:40+00:00" />
<meta property="article:modified_time" content="2018-04-03T01:08:19+00:00" />
<meta property="og:site_name" content="The Official Site of Area Auto Racing News and Len Sammons Productions" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Feature Winners: March 27 &#8211; April 2, 2018" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Visit the post for more." />

<!-- End Jetpack Open Graph Tags -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body id="top" class="post-template-default single single-post postid-10206 single-format-standard lazy-enabled wpb-js-composer js-comp-ver-5.0.1 vc_responsive">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

	
	
		<div id="mobile-menu"  class="mobile-hide-icons"></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed-all">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header full-logo center-logo">
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="The Official Site of Area Auto Racing News and Len Sammons Productions" href="https://aarn.com/">
					<img src="http://aarn.com/wp-content/uploads/2019/07/main_page_logo.png" alt="The Official Site of Area Auto Racing News and Len Sammons Productions"  /><strong>The Official Site of Area Auto Racing News and Len Sammons Productions Area Auto Racing News</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-402"><a href="http://aarn.com">Home</a></li>
<li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="http://www.aarn.com/index.php">Area Auto Racing News</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-165" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-165"><a href="https://aarn.com/category/feature-winners/">Feature Winners</a></li>
	<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169"><a href="https://aarn.com/category/newsmaker-of-the-week/">Newsmaker of the Week</a></li>
	<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168"><a href="https://aarn.com/category/from-the-paper/">From the Paper</a></li>
	<li id="menu-item-401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-401"><a href="https://aarn.com/category/this-week-in-aarn/">This Week in AARN</a></li>
	<li id="menu-item-452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-452"><a href="https://aarn.com/congratulations-personal-message-ads/">Congratulations &#038; Personal Message Ads</a></li>
	<li id="menu-item-219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219"><a href="https://aarn.com/advertise-with-us/">Advertise</a></li>
	<li id="menu-item-400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-400"><a href="https://aarn.com/category/trivia-photo/">Trivia Photo</a></li>
	<li id="menu-item-223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-223"><a href="https://aarn.com/submit-change-of-address/">Submit Change of Address</a></li>
	<li id="menu-item-8131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8131"><a href="https://aarn.com/contact/">Contact</a></li>
</ul>
</li>
<li id="menu-item-8979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8979"><a href="http://areaautoracingnews.zenfolio.com/">Photos</a></li>
<li id="menu-item-8135" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8135 mega-menu mega-recent-featured "><a href="https://aarn.com/category/feature-winners/">Feature Winners</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/10/09/feature-winner-october-8-14-2019/" title="Feature Winner: October 8 &#8211; 14, 2019">Feature Winner: October 8 &#8211; 14, 2019</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>October 9, 2019</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/10/02/feature-winner-october-1-7-2019/" title="Feature Winner: October 1 &#8211; 7, 2019">Feature Winner: October 1 &#8211; 7, 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>October 2, 2019</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/25/feature-winner-september-24-2019/" title="Feature Winner: September 24 &#8211; 30, 2019">Feature Winner: September 24 &#8211; 30, 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 25, 2019</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/18/feature-winners-september-17-23-2019/" title="Feature Winners: September 17 &#8211; 23, 2019">Feature Winners: September 17 &#8211; 23, 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 18, 2019</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/11/feature-winners-september-10-16-2019/" title="Feature Winners: September 10 &#8211; 16, 2019">Feature Winners: September 10 &#8211; 16, 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 11, 2019</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/04/feature-winners-september-3-9-2019/" title="Feature Winners: September 3 &#8211; 9, 2019">Feature Winners: September 3 &#8211; 9, 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>September 4, 2019</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/08/28/feature-winners-august-27-september-2-2019/" title="Feature Winners: August 27 &#8211; September 2, 2019">Feature Winners: August 27 &#8211; September 2, 2019</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>August 28, 2019</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-8133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8133 mega-menu mega-cat "><a href="https://aarn.com/category/newsmaker-of-the-week/">Newsmaker</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-8133-4" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2019/10/07/newsmaker-of-the-week-brent-marks-3/" title="Newsmaker of the Week // Brent Marks"><img src="https://aarn.com/wp-content/uploads/2019/10/NEWSMAKER-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Brent Marks" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/10/07/newsmaker-of-the-week-brent-marks-3/" title="Newsmaker of the Week // Brent Marks">Newsmaker of the Week // Brent Marks</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>October 7, 2019</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2019/09/30/newsmaker-of-the-week-stewart-friesen-11/" title="Newsmaker of the Week // Stewart Friesen"><img src="https://aarn.com/wp-content/uploads/2019/09/NEWSMAKER-4-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Stewart Friesen" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/30/newsmaker-of-the-week-stewart-friesen-11/" title="Newsmaker of the Week // Stewart Friesen">Newsmaker of the Week // Stewart Friesen</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>September 30, 2019</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2019/09/23/newsmaker-of-the-week-mike-gular-2/" title="Newsmaker of the Week // Mike Gular"><img src="https://aarn.com/wp-content/uploads/2019/09/NEWSMAKER-3-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Mike Gular" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/23/newsmaker-of-the-week-mike-gular-2/" title="Newsmaker of the Week // Mike Gular">Newsmaker of the Week // Mike Gular</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>September 23, 2019</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2019/09/16/newsmaker-of-the-week-mike-stefanik/" title="Newsmaker of the Week // Mike Stefanik"><img src="https://aarn.com/wp-content/uploads/2019/09/NEWSMAKER-2-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Mike Stefanik" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2019/09/16/newsmaker-of-the-week-mike-stefanik/" title="Newsmaker of the Week // Mike Stefanik">Newsmaker of the Week // Mike Stefanik</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>September 16, 2019</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content -->
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-8134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8134 mega-menu mega-cat "><a href="https://aarn.com/category/from-the-paper/">From the Paper</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-8134-8" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2018/06/27/tragedy-in-turn-three-the-passing-of-another-of-racings-greats-jason-johnson/" title="Tragedy In Turn Three: The Passing Of Another Of Racing’s Greats Jason Johnson"><img src="https://aarn.com/wp-content/uploads/2018/06/JJR-310x165.jpg" width="310" height="165" alt="Tragedy In Turn Three: The Passing Of Another Of Racing’s Greats Jason Johnson" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2018/06/27/tragedy-in-turn-three-the-passing-of-another-of-racings-greats-jason-johnson/" title="Tragedy In Turn Three: The Passing Of Another Of Racing’s Greats Jason Johnson">Tragedy In Turn Three: The Passing Of Another Of Racing’s Greats Jason Johnson</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>June 27, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2018/05/24/chris-windom-hopes-for-an-indianapolis-start-ends-with-a-crash/" title="Chris Windom Hopes For An Indianapolis Start Ends With A Crash"><img src="https://aarn.com/wp-content/uploads/2018/05/On-AARN-Now-2-310x165.jpg" width="310" height="165" alt="Chris Windom Hopes For An Indianapolis Start Ends With A Crash" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2018/05/24/chris-windom-hopes-for-an-indianapolis-start-ends-with-a-crash/" title="Chris Windom Hopes For An Indianapolis Start Ends With A Crash">Chris Windom Hopes For An Indianapolis Start Ends With A Crash</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>May 24, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2018/05/17/hall-of-fame-driver-race-car-innovator-maynard-troyer-passes-at-age-79/" title="Hall Of Fame Driver, Race Car Innovator Maynard Troyer Passes At Age 79"><img src="https://aarn.com/wp-content/uploads/2018/05/On-AARN-Now-1-310x165.jpg" width="310" height="165" alt="Hall Of Fame Driver, Race Car Innovator Maynard Troyer Passes At Age 79" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2018/05/17/hall-of-fame-driver-race-car-innovator-maynard-troyer-passes-at-age-79/" title="Hall Of Fame Driver, Race Car Innovator Maynard Troyer Passes At Age 79">Hall Of Fame Driver, Race Car Innovator Maynard Troyer Passes At Age 79</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>May 17, 2018</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2018/05/16/sprint-car-driver-brett-wanner-doesnt-let-hearing-impairment-affect-racing-or-life/" title="Driver Brett Wanner Doesn’t Let Hearing Impairment Affect Racing Or Life"><img src="https://aarn.com/wp-content/uploads/2018/05/On-AARN-Now-310x165.jpg" width="310" height="165" alt="Driver Brett Wanner Doesn’t Let Hearing Impairment Affect Racing Or Life" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2018/05/16/sprint-car-driver-brett-wanner-doesnt-let-hearing-impairment-affect-racing-or-life/" title="Driver Brett Wanner Doesn’t Let Hearing Impairment Affect Racing Or Life">Driver Brett Wanner Doesn’t Let Hearing Impairment Affect Racing Or Life</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>May 16, 2018</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content -->
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-9702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9702"><a href="http://motorsportstradeshow.com/">Motorsports Show</a></li>
<li id="menu-item-7490" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7490"><a target="_blank" href="http://www.indoorautoracing.com">Indoor Racing Series</a></li>
<li id="menu-item-4189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4189"><a href="http://store.aarn.com">E-Store</a></li>
<li id="menu-item-4567" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4567"><a href="https://aarn.com/adverts-list/">Classifieds</a></li>
<li id="menu-item-8130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8130"><a href="https://aarn.com/contact/">Contact</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container sidebar-left">
	
	
	
	
	
	<div class="content">

		
		
		

		
		<article class="post-listing post-10206 post type-post status-publish format-standard  category-feature-winners" id="the-post">
			
			<div class="single-post-thumb">
					</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Feature Winners: March 27 &#8211; April 2, 2018</span></h1>

							
				<div class="entry">
					
					
					<div>
<div>
<div><span style="font-size: large;"><br />
</span><div class="table-responsive"><table  style="width:100%; "  class="easy-table easy-table-cuscosky " >
<tbody>
<tr><td ></div></td>
</tr>

<tr><td ></div></td>
</tr>

<tr><td ></div></td>
</tr>

<tr><td >Attica, OH</td>
<td >(Fri.) WEATHER</td>
</tr>

<tr><td ></td>
<td >(Sat.) WEATHER</td>
</tr>

<tr><td >BAP'S, Susquehanna, PA </td>
<td >(Super Spt) FRANKIE HERR</td>
</tr>

<tr><td ></td>
<td >(LM) BOBBY BEARD</td>
</tr>

<tr><td >Bridgeport, NJ: Poker Series</td>
<td >(Fri., Practice) WEATHER</td>
</tr>

<tr><td ></td>
<td >(Sat., Modified) RYAN WATT</td>
</tr>

<tr><td >Hagerstown, MD</td>
<td > (LM) TREVER FEATHERS</td>
</tr>

<tr><td ><div>Lincoln, PA </td>
<td >(410 Sprint) BRIAN MONTIETH</div></td>
</tr>

<tr><td ><div></td>
<td > (358 Sprint) JEFF HALLIGAN</div></td>
</tr>

<tr><td ><div></div></td>
</tr>

<tr><td >New Egypt, NJ</td>
<td > (Sat., Practice) POSTPONED UNTIL FRIDAY APRIL 6</td>
</tr>

<tr><td >NCRA 360 Sprint: Park City, KS </td>
<td >(Fri.)  TIM CRAWLEY</td>
</tr>

<tr><td ></td>
<td > (Sat.) BLAKE HAHN</td>
</tr>

<tr><td >PASS LM: Hickory, NC </td>
<td > PRESTON PELTIER</td>
</tr>

<tr><td ><div>Path Valley, PA</td>
<td > (Mod) BRAD KLING</div></td>
</tr>

<tr><td >Port Royal, PA</td>
<td > (410 Sprint) LANCE DEWEASE</td>
</tr>

<tr><td ></td>
<td >(LM) JEFF RINE</td>
</tr>

<tr><td >Potomac, MD</td>
<td > (LLM) LOGAN ROBERSON</td>
</tr>

<tr><td ><div></td>
</tr>

<tr><td ><div></td>
</tr>

<tr><td ><div>SMRS Mod: Hickory, NC  </td>
<td >MATT HIRSCHMAN</div></td>
</tr>

<tr><td ><div></td>
</tr>

<tr></tr>

<tr></tr>

<tr><td ></div></td>
</tr>

<tr><td ></div></td>
</tr>

<tr><td ></div></td>
</tr>

<tr><td >USAC: Lawrenceburg, IN (Sprint)</td>
<td > WEATHER</td>
</tr>

<tr><td >Williams Grove, PA </td>
<td >(410 Sprint) RYAN TAYLOR</td>
</tr>

<tr><td ></td>
<td >(358 Sprint) JEFF HALLIGAN</td>
</tr>

<tr><td >Winchester, VA </td>
<td >(KLM) AUSTIN STOVER</td>
</tr>

<tr><td ><p class="p1"></td>
</tr>
</tbody></table></div>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2018-03-28T12:18:40+00:00","datePublished":"2018-03-28T12:18:40+00:00","dateModified":"2018-04-02T21:08:19+00:00","headline":"Feature Winners: March 27 &#8211; April 2, 2018","name":"Feature Winners: March 27 &#8211; April 2, 2018","keywords":[],"url":"https:\/\/aarn.com\/2018\/03\/28\/feature-winners-march-27-april-2-2018\/","description":"","copyrightYear":"2018","publisher":{"@id":"#Publisher","@type":"Organization","name":"The Official Site of Area Auto Racing News and Len Sammons Productions","logo":{"@type":"ImageObject","url":"http:\/\/aarn.com\/wp-content\/uploads\/2019\/07\/main_page_logo.png"},"sameAs":["http:\/\/www.facebook.com\/areaautoracingnews","http:\/\/www.twitter.com\/aarn"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/aarn.com\/2018\/03\/28\/feature-winners-march-27-april-2-2018\/"},"author":{"@type":"Person","name":"Lenny Sammons","url":"https:\/\/aarn.com\/author\/lenny-sammons\/"},"articleSection":"Feature Winners","articleBody":"\r\n\r\n\r\n"}</script>
		</article><!-- .post-listing -->
		

		<div class="e3lan e3lan-post">
			<a href="http://store.aarn.com" title="" target="_blank"rel="nofollow">
				<img src="http://aarn.com/wp-content/uploads/2015/10/subscribe-2016.jpg" alt="" />
			</a>
				</div>
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<h3><a href="https://aarn.com/2019/10/09/feature-winner-october-8-14-2019/" rel="bookmark">Feature Winner: October 8 &#8211; 14, 2019</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>October 9, 2019</span></p>
			</div>
						<div class="related-item">
							
				<h3><a href="https://aarn.com/2019/10/02/feature-winner-october-1-7-2019/" rel="bookmark">Feature Winner: October 1 &#8211; 7, 2019</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>October 2, 2019</span></p>
			</div>
						<div class="related-item">
							
				<h3><a href="https://aarn.com/2019/09/25/feature-winner-september-24-2019/" rel="bookmark">Feature Winner: September 24 &#8211; 30, 2019</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>September 25, 2019</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
		
		
				
<div id="comments">


<div class="clear"></div>


</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
			<div id="text-html-widget-4" class="text-html-box" >
			<div class="widget-container"><a href="http://digital.turn-page.com/t/30678"><img class="alignnone wp-image-373 size-full" src="http://www.aarn.com/wp-content/uploads/2015/09/DIGITAL_EDITION.png" alt="DIGITAL_EDITION" width="288" height="237" /></a>
<h2 style="text-align: left;"><a title="Sign-Up for the Digital Edition of AARN" href="http://aarn.com/?page_id=1376">Click Here to Sign-Up for the Digital Edition of AARN</a></h2><br></div>			</div>
		<div id="login-widget-3" class="widget login-widget"><div class="widget-top"><h4>Classifieds Login</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div id="login-form">
			<form name="loginform" id="loginform" action="https://aarn.com/wp-login.php" method="post">
				<p id="log-username"><input type="text" name="log" id="log" title="Username" value="Username" onfocus="if (this.value == 'Username') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Username';}"  size="33" /></p>
				<p id="log-pass"><input type="password" name="pwd" id="pwd" title="Password" value="Password" onfocus="if (this.value == 'Password') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Password';}" size="33" /></p>
				<input type="submit" name="submit" value="Log in" class="login-button" />
				<label for="rememberme"><input name="rememberme" id="rememberme" type="checkbox" checked="checked" value="forever" /> Remember Me</label>
				<input type="hidden" name="redirect_to" value="/2018/03/28/feature-winners-march-27-april-2-2018/"/>
			</form>
			<ul class="login-links">
				<li><a href="https://aarn.com/wp-login.php?action=register">Register</a></li>				<li><a href="https://aarn.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Faarn.com">Lost your password?</a></li>
			</ul>
		</div>
	</div></div><!-- .widget /--><div id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-top"><h4>Classifieds Toolbox</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="menu-classifieds-container"><ul id="menu-classifieds" class="menu"><li id="menu-item-3734" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3734"><a href="https://aarn.com/adverts-2/add/">Create a New Ad</a></li>
<li id="menu-item-3733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3733"><a href="https://aarn.com/adverts-2/manage/">Manage Your Ad</a></li>
<li id="menu-item-3763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3763"><a href="https://aarn.com/adverts/">Classifieds Main Page</a>
<ul class="sub-menu">
	<li id="menu-item-3751" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3751"><a href="https://aarn.com/advert-category/collectibles/">Collectibles</a></li>
	<li id="menu-item-3752" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3752"><a href="https://aarn.com/advert-category/help-wanted/">Help Wanted</a></li>
	<li id="menu-item-3753" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3753"><a href="https://aarn.com/advert-category/miscellaneous/">Miscellaneous</a></li>
	<li id="menu-item-3754" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3754"><a href="https://aarn.com/advert-category/parts-engines/">Parts &#038; Engines</a></li>
	<li id="menu-item-3755" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3755"><a href="https://aarn.com/advert-category/race-cars/">Race Cars</a></li>
	<li id="menu-item-3756" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3756"><a href="https://aarn.com/advert-category/ride-wanted/">Ride Wanted</a></li>
	<li id="menu-item-3757" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3757"><a href="https://aarn.com/advert-category/services/">Services</a></li>
	<li id="menu-item-3758" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3758"><a href="https://aarn.com/advert-category/shop-equipment/">Shop Equipment</a></li>
	<li id="menu-item-3759" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3759"><a href="https://aarn.com/advert-category/tickets/">Tickets</a></li>
	<li id="menu-item-3760" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3760"><a href="https://aarn.com/advert-category/tow-vehicles-trailers/">Tow Vehicles &#038; Trailers</a></li>
	<li id="menu-item-3761" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3761"><a href="https://aarn.com/advert-category/videosphotos/">Videos/Photos</a></li>
	<li id="menu-item-3762" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3762"><a href="https://aarn.com/advert-category/wanted/">Wanted</a></li>
</ul>
</li>
</ul></div></div></div><!-- .widget /--><div id="facebook-likebox-3" class="widget widget_facebook_likebox"><div class="widget-top"><h4><a href="https://www.facebook.com/areaautoracingnews">Find Us on Facebook</a></h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/areaautoracingnews" data-width="285"  data-height="700" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/areaautoracingnews"><a href="https://www.facebook.com/areaautoracingnews">Find Us on Facebook</a></blockquote></div>
		</div>
		</div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
					</div>
				
		<div class="alignleft">
					</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
<div id="fb-root"></div>
<!-- analytics-code google analytics tracking code --><script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-55275551-1', 'auto');
	ga('send', 'pageview');

</script><!--  -->	<div style="display:none">
	</div>
<div id="reading-position-indicator"></div><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/aarn.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201941.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.2',blog:'70528605',post:'10206',tz:'-4',srv:'aarn.com'} ]);
	_stq.push([ 'clickTrackerInit', '70528605', '10206' ]);
</script>
</body>
</html>