<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://aarn.com/xmlrpc.php" />
<title>Feature Winners: March 30 &#8211; April 5, 2021 &#8211; The Official Site of Area Auto Racing News and Len Sammons Productions</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Official Site of Area Auto Racing News and Len Sammons Productions &raquo; Feed" href="https://aarn.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Official Site of Area Auto Racing News and Len Sammons Productions &raquo; Comments Feed" href="https://aarn.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/aarn.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://aarn.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://aarn.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://aarn.com/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://aarn.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='upw_theme_standard-css'  href='https://aarn.com/wp-content/plugins/ultimate-posts-widget/css/upw-theme-standard.min.css' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://aarn.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css'  href='https://aarn.com/wp-content/plugins/easy-table/themes/cuscosky/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://aarn.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='zfp_style-css'  href='https://aarn.com/wp-content/plugins/zenfoliopress/zfp.css' type='text/css' media='all' />
<link rel='stylesheet' id='zfp_slimbox2-css'  href='https://aarn.com/wp-content/plugins/zenfoliopress/slimbox2.css' type='text/css' media='all' />
<script type='text/javascript' src='https://aarn.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/zenfoliopress/slimbox2.js'></script>
<link rel='https://api.w.org/' href='https://aarn.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://aarn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://aarn.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Newsmaker of the Week // Mike Maresca' href='https://aarn.com/2021/03/29/newsmaker-of-the-week-mike-maresca/' />
<meta name="generator" content="WordPress 4.9.16" />
<link rel="canonical" href="https://aarn.com/2021/03/31/feature-winners-march-31-april-7-2021/" />
<link rel='shortlink' href='https://wp.me/p4LVI9-4iZ' />
<link rel="alternate" type="application/json+oembed" href="https://aarn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Faarn.com%2F2021%2F03%2F31%2Ffeature-winners-march-31-april-7-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://aarn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Faarn.com%2F2021%2F03%2F31%2Ffeature-winners-march-31-april-7-2021%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="shortcut icon" href="http://03a4cfb.netsolhost.com/WordPress/wp-content/uploads/2014/12/aarnfavicon.png" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://aarn.com/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://aarn.com/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://aarn.com/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://aarn.com/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://aarn.com/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<link href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '206255333205885', {
em: 'insert_email_variable'
});
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=206255333205885&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->



<style type="text/css" media="screen">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</style>

<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://aarn.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Feature Winners: March 30 &#8211; April 5, 2021" />
<meta property="og:url" content="https://aarn.com/2021/03/31/feature-winners-march-31-april-7-2021/" />
<meta property="og:description" content="Visit the post for more." />
<meta property="article:published_time" content="2021-03-31T17:53:44+00:00" />
<meta property="article:modified_time" content="2021-03-31T19:05:48+00:00" />
<meta property="og:site_name" content="The Official Site of Area Auto Racing News and Len Sammons Productions" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Feature Winners: March 30 &#8211; April 5, 2021" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Visit the post for more." />

<!-- End Jetpack Open Graph Tags -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body id="top" class="post-template-default single single-post postid-16553 single-format-standard lazy-enabled wpb-js-composer js-comp-ver-5.0.1 vc_responsive">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

	
	
		<div id="mobile-menu"  class="mobile-hide-icons"></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed-all">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header full-logo center-logo">
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="The Official Site of Area Auto Racing News and Len Sammons Productions" href="https://aarn.com/">
					<img src="http://aarn.com/wp-content/uploads/2019/07/main_page_logo.png" alt="The Official Site of Area Auto Racing News and Len Sammons Productions"  /><strong>The Official Site of Area Auto Racing News and Len Sammons Productions Area Auto Racing News</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-402"><a href="http://aarn.com">Home</a></li>
<li id="menu-item-133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-133"><a href="http://www.aarn.com/index.php">Area Auto Racing News</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-165" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-165"><a href="https://aarn.com/category/feature-winners/">Feature Winners</a></li>
	<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-169"><a href="https://aarn.com/category/newsmaker-of-the-week/">Newsmaker of the Week</a></li>
	<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168"><a href="https://aarn.com/category/from-the-paper/">From the Paper</a></li>
	<li id="menu-item-401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-401"><a href="https://aarn.com/category/this-week-in-aarn/">This Week in AARN</a></li>
	<li id="menu-item-452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-452"><a href="https://aarn.com/congratulations-personal-message-ads/">Congratulations &#038; Personal Message Ads</a></li>
	<li id="menu-item-219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219"><a href="https://aarn.com/advertise-with-us/">Advertise</a></li>
	<li id="menu-item-400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-400"><a href="https://aarn.com/category/trivia-photo/">Trivia Photo</a></li>
	<li id="menu-item-223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-223"><a href="https://aarn.com/submit-change-of-address/">Submit Change of Address</a></li>
	<li id="menu-item-8131" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8131"><a href="https://aarn.com/contact/">Contact</a></li>
</ul>
</li>
<li id="menu-item-8979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8979"><a href="http://areaautoracingnews.zenfolio.com/">Photos</a></li>
<li id="menu-item-8135" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-8135 mega-menu mega-recent-featured "><a href="https://aarn.com/category/feature-winners/">Feature Winners</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-recent-post"><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/31/feature-winners-march-31-april-7-2021/" title="Feature Winners: March 30 &#8211; April 5, 2021">Feature Winners: March 30 &#8211; April 5, 2021</a></h3>
						<span class="tie-date"><i class="fa fa-clock-o"></i>March 31, 2021</span>
						</div> <!-- mega-recent-post --><div class="mega-check-also"><ul><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/24/feature-winners-march-23-30-2021/" title="Feature Winners: March 23 &#8211; 29, 2021">Feature Winners: March 23 &#8211; 29, 2021</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 24, 2021</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/18/feature-winners-march-16-22-2021/" title="Feature Winners: March 16 &#8211; 22, 2021">Feature Winners: March 16 &#8211; 22, 2021</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 18, 2021</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/10/feature-winners-march-9-15-2021/" title="Feature Winners: March 9 &#8211; 15, 2021">Feature Winners: March 9 &#8211; 15, 2021</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 10, 2021</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/03/feature-winners-march-2-8-2021/" title="Feature Winners: March 2 &#8211; 8, 2021">Feature Winners: March 2 &#8211; 8, 2021</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>March 3, 2021</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/02/23/feature-winners-feb-23-march-1-2021/" title="Feature Winners: Feb. 23 &#8211; March 1, 2021">Feature Winners: Feb. 23 &#8211; March 1, 2021</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>February 23, 2021</span></li><li><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/02/17/feature-winners-february-16-22-2021/" title="Feature Winners: February 16 &#8211; 22, 2021">Feature Winners: February 16 &#8211; 22, 2021</a></h3><span class="tie-date"><i class="fa fa-clock-o"></i>February 17, 2021</span></li></ul></div> <!-- mega-check-also -->
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-8133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8133 mega-menu mega-cat "><a href="https://aarn.com/category/newsmaker-of-the-week/">Newsmaker</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-8133-4" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2021/03/29/newsmaker-of-the-week-mike-maresca/" title="Newsmaker of the Week // Mike Maresca"><img src="https://aarn.com/wp-content/uploads/2021/03/NEWSMAKER-4-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Mike Maresca" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/29/newsmaker-of-the-week-mike-maresca/" title="Newsmaker of the Week // Mike Maresca">Newsmaker of the Week // Mike Maresca</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>March 29, 2021</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2021/03/22/newsmaker-of-the-week-eric-mauriello-3/" title="Newsmaker of the Week // Eric Mauriello"><img src="https://aarn.com/wp-content/uploads/2021/03/NEWSMAKER-3-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Eric Mauriello" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/22/newsmaker-of-the-week-eric-mauriello-3/" title="Newsmaker of the Week // Eric Mauriello">Newsmaker of the Week // Eric Mauriello</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>March 22, 2021</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2021/03/15/newsmaker-of-the-week-matt-sheppard-9/" title="Newsmaker of the Week // Matt Sheppard"><img src="https://aarn.com/wp-content/uploads/2021/03/NEWSMAKER-2-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Matt Sheppard" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/15/newsmaker-of-the-week-matt-sheppard-9/" title="Newsmaker of the Week // Matt Sheppard">Newsmaker of the Week // Matt Sheppard</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>March 15, 2021</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2021/03/08/newsmaker-of-the-week-kyle-larson-10/" title="Newsmaker of the Week // Kyle Larson"><img src="https://aarn.com/wp-content/uploads/2021/03/NEWSMAKER-1-310x165.jpg" width="310" height="165" alt="Newsmaker of the Week // Kyle Larson" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2021/03/08/newsmaker-of-the-week-kyle-larson-10/" title="Newsmaker of the Week // Kyle Larson">Newsmaker of the Week // Kyle Larson</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>March 8, 2021</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content -->
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-8134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8134 mega-menu mega-cat "><a href="https://aarn.com/category/from-the-paper/">From the Paper</a>
<div class="mega-menu-block menu-sub-content">

<div class="mega-menu-content">
<div class="mega-cat-wrapper">  <div class="mega-cat-content"><div id="mega-cat-8134-8" class="mega-cat-content-tab"><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2020/06/02/new-york-tracks-good-to-race-without-spectators/" title="New York Tracks &#8211; Good To Race&#8230;. Without Spectators"><img src="https://aarn.com/wp-content/uploads/2020/06/OCFS-NOTES-ba-7927-310x165.jpg" width="310" height="165" alt="New York Tracks &#8211; Good To Race&#8230;. Without Spectators" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2020/06/02/new-york-tracks-good-to-race-without-spectators/" title="New York Tracks &#8211; Good To Race&#8230;. Without Spectators">New York Tracks &#8211; Good To Race&#8230;. Without Spectators</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>June 2, 2020</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2020/05/04/covid-19-hits-home-aarn-editor-len-sammons-mother-maude-fighting-back-from-coronavirus-infection/" title="COVID-19 Hits Home: AARN Editor Len Sammons, Mother Maude Fighting Back From Coronavirus Infection"><img src="https://aarn.com/wp-content/uploads/2020/05/season_highlight_BYurko-5-660x330-copy-310x165.jpg" width="310" height="165" alt="COVID-19 Hits Home: AARN Editor Len Sammons, Mother Maude Fighting Back From Coronavirus Infection" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2020/05/04/covid-19-hits-home-aarn-editor-len-sammons-mother-maude-fighting-back-from-coronavirus-infection/" title="COVID-19 Hits Home: AARN Editor Len Sammons, Mother Maude Fighting Back From Coronavirus Infection">COVID-19 Hits Home: AARN Editor Len Sammons, Mother Maude Fighting Back From Coronavirus Infection</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>May 4, 2020</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><div class="post-thumbnail"><a class="mega-menu-link" href="https://aarn.com/2020/03/24/14652/" title="AUTOMATIC RENEWAL &#8211; Now Available!"><img src="https://aarn.com/wp-content/uploads/2020/03/AARN-Website-Auto-Renewal-310x165.jpg" width="310" height="165" alt="AUTOMATIC RENEWAL &#8211; Now Available!" /><span class="fa overlay-icon"></span></a></div><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2020/03/24/14652/" title="AUTOMATIC RENEWAL &#8211; Now Available!">AUTOMATIC RENEWAL &#8211; Now Available!</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>March 24, 2020</span>
							</div> <!-- mega-menu-post --><div class="mega-menu-post"><h3 class="post-box-title"><a class="mega-menu-link" href="https://aarn.com/2020/03/17/coronavirus-live-updates/" title="Coronavirus LIVE UPDATES">Coronavirus LIVE UPDATES</a></h3>
									<span class="tie-date"><i class="fa fa-clock-o"></i>March 17, 2020</span>
							</div> <!-- mega-menu-post --></div><!-- .mega-cat-content-tab --> </div> <!-- .mega-cat-content -->
								<div class="clear"></div>
							</div> <!-- .mega-cat-Wrapper --> 
</div><!-- .mega-menu-content --> 
</div><!-- .mega-menu-block --> 
</li>
<li id="menu-item-9702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9702"><a href="http://motorsportstradeshow.com/">Motorsports Show</a></li>
<li id="menu-item-7490" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7490"><a target="_blank" href="http://www.indoorautoracing.com">Indoor Racing Series</a></li>
<li id="menu-item-4189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4189"><a href="http://store.aarn.com">E-Store</a></li>
<li id="menu-item-4567" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4567"><a href="https://aarn.com/adverts-list/">Classifieds</a></li>
<li id="menu-item-8130" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8130"><a href="https://aarn.com/contact/">Contact</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container sidebar-left">
	
	
	
	
	
	<div class="content">

		
		
		

		
		<article class="post-listing post-16553 post type-post status-publish format-standard  category-feature-winners" id="the-post">
			
			<div class="single-post-thumb">
					</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Feature Winners: March 30 &#8211; April 5, 2021</span></h1>

							
				<div class="entry">
					
					
					<div><div class="table-responsive"><table  style="width:100%; "  class="easy-table easy-table-cuscosky " >
<tbody>
<tr><td ></div></td>
</tr>

<tr><td ><div></div></td>
</tr>

<tr><td >BAPS, PA </td>
<td >(Super Sport)</td>
</tr>

<tr><td ></td>
<td >(LLM)</td>
</tr>

<tr><td >Bedford, PA </td>
<td >(LM)</td>
</tr>

<tr><td >Big Diamond, PA </td>
<td >(358 Mod)</td>
</tr>

<tr><td >Five Mile Point, NY </td>
<td >(Spts)</td>
</tr>

<tr><td >Grandview, PA </td>
<td >(Mod)</td>
</tr>

<tr><td >Hagerstown, MD </td>
<td >(SLM)</td>
</tr>

<tr><td >Lincoln, PA  </td>
<td >(410 Sprint)</td>
</tr>

<tr><td ></td>
<td >(358 Sprint)</td>
</tr>

<tr><td >Mahoning Valley, PA </td>
<td >(Mod)</td>
</tr>

<tr><td ></td>
<td >(LM)</td>
</tr>

<tr><td >New Egypt, NJ </td>
<td >(Mod)</td>
</tr>

<tr><td >Orange County, NY </td>
<td >(Mod)</td>
</tr>

<tr><td >Path Valley. PA </td>
<td >(Super Sportsman)</td>
</tr>

<tr><td >Port Royal, PA  </td>
<td >(410 Sprint)</td>
</tr>

<tr><td ></td>
<td >(SLM)</td>
</tr>

<tr><td >PASS LM (Hickory, NC)</td>
<td > </td>
</tr>

<tr><td >Potomac, MD </td>
<td >(LM)</td>
</tr>

<tr><td >SMART Tour: </td>
<td >South Boston, VA (Sat.)</td>
</tr>

<tr><td >Southern All Star Series (Dublin, GA)</td>
<td ></td>
</tr>

<tr><td >Tyler County, WV </td>
<td >(LM)</td>
</tr>

<tr><td >USAC East: </td>
<td >Bridgeport, NJ (Sat.)</td>
</tr>

<tr><td >Williams Grove, PA </td>
<td >(410 Sprint)</td>
</tr>

<tr><td ><div></div></td>
</tr>

<tr><td ><div></td>
</tr>
</tbody></table></div></div>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","dateCreated":"2021-03-31T13:53:44+00:00","datePublished":"2021-03-31T13:53:44+00:00","dateModified":"2021-03-31T15:05:48+00:00","headline":"Feature Winners: March 30 &#8211; April 5, 2021","name":"Feature Winners: March 30 &#8211; April 5, 2021","keywords":[],"url":"https:\/\/aarn.com\/2021\/03\/31\/feature-winners-march-31-april-7-2021\/","description":"","copyrightYear":"2021","publisher":{"@id":"#Publisher","@type":"Organization","name":"The Official Site of Area Auto Racing News and Len Sammons Productions","logo":{"@type":"ImageObject","url":"http:\/\/aarn.com\/wp-content\/uploads\/2019\/07\/main_page_logo.png"},"sameAs":["http:\/\/www.facebook.com\/areaautoracingnews","http:\/\/www.twitter.com\/aarn"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/aarn.com\/2021\/03\/31\/feature-winners-march-31-april-7-2021\/"},"author":{"@type":"Person","name":"Lenny Sammons","url":"https:\/\/aarn.com\/author\/lenny-sammons\/"},"articleSection":"Feature Winners","articleBody":""}</script>
		</article><!-- .post-listing -->
		

		<div class="e3lan e3lan-post">
			<a href="http://store.aarn.com" title="" target="_blank"rel="nofollow">
				<img src="http://aarn.com/wp-content/uploads/2015/10/subscribe-2016.jpg" alt="" />
			</a>
				</div>
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<h3><a href="https://aarn.com/2021/03/24/feature-winners-march-23-30-2021/" rel="bookmark">Feature Winners: March 23 &#8211; 29, 2021</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>March 24, 2021</span></p>
			</div>
						<div class="related-item">
							
				<h3><a href="https://aarn.com/2021/03/18/feature-winners-march-16-22-2021/" rel="bookmark">Feature Winners: March 16 &#8211; 22, 2021</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>March 18, 2021</span></p>
			</div>
						<div class="related-item">
							
				<h3><a href="https://aarn.com/2021/03/10/feature-winners-march-9-15-2021/" rel="bookmark">Feature Winners: March 9 &#8211; 15, 2021</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>March 10, 2021</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
		
		
				
<div id="comments">


<div class="clear"></div>


</div><!-- #comments -->

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
			<div id="text-html-widget-4" class="text-html-box" >
			<div class="widget-container"><a href="http://digital.turn-page.com/t/30678"><img class="alignnone wp-image-373 size-full" src="http://www.aarn.com/wp-content/uploads/2015/09/DIGITAL_EDITION.png" alt="DIGITAL_EDITION" width="288" height="237" /></a>
<h2 style="text-align: left;"><a title="Sign-Up for the Digital Edition of AARN" href="http://aarn.com/?page_id=1376">Click Here to Sign-Up for the Digital Edition of AARN</a></h2><br></div>			</div>
		<div id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-top"><h4>Classifieds Toolbox</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="menu-classifieds-container"><ul id="menu-classifieds" class="menu"><li id="menu-item-3734" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3734"><a href="https://aarn.com/adverts-2/add/">Create a New Ad</a></li>
<li id="menu-item-3733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3733"><a href="https://aarn.com/adverts-2/manage/">Manage Your Ad</a></li>
<li id="menu-item-3763" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-3763"><a href="https://aarn.com/adverts/">Classifieds Main Page</a>
<ul class="sub-menu">
	<li id="menu-item-3751" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3751"><a href="https://aarn.com/advert-category/collectibles/">Collectibles</a></li>
	<li id="menu-item-3752" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3752"><a href="https://aarn.com/advert-category/help-wanted/">Help Wanted</a></li>
	<li id="menu-item-3753" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3753"><a href="https://aarn.com/advert-category/miscellaneous/">Miscellaneous</a></li>
	<li id="menu-item-3754" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3754"><a href="https://aarn.com/advert-category/parts-engines/">Parts &#038; Engines</a></li>
	<li id="menu-item-3755" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3755"><a href="https://aarn.com/advert-category/race-cars/">Race Cars</a></li>
	<li id="menu-item-3756" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3756"><a href="https://aarn.com/advert-category/ride-wanted/">Ride Wanted</a></li>
	<li id="menu-item-3757" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3757"><a href="https://aarn.com/advert-category/services/">Services</a></li>
	<li id="menu-item-3758" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3758"><a href="https://aarn.com/advert-category/shop-equipment/">Shop Equipment</a></li>
	<li id="menu-item-3759" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3759"><a href="https://aarn.com/advert-category/tickets/">Tickets</a></li>
	<li id="menu-item-3760" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3760"><a href="https://aarn.com/advert-category/tow-vehicles-trailers/">Tow Vehicles &#038; Trailers</a></li>
	<li id="menu-item-3761" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3761"><a href="https://aarn.com/advert-category/videosphotos/">Videos/Photos</a></li>
	<li id="menu-item-3762" class="menu-item menu-item-type-taxonomy menu-item-object-advert_category menu-item-3762"><a href="https://aarn.com/advert-category/wanted/">Wanted</a></li>
</ul>
</li>
</ul></div></div></div><!-- .widget /--><div id="facebook-likebox-3" class="widget widget_facebook_likebox"><div class="widget-top"><h4><a href="https://www.facebook.com/areaautoracingnews">Find Us on Facebook</a></h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/areaautoracingnews" data-width="285"  data-height="700" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/areaautoracingnews"><a href="https://www.facebook.com/areaautoracingnews">Find Us on Facebook</a></blockquote></div>
		</div>
		</div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
					</div>
				
		<div class="alignleft">
					</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
<div id="fb-root"></div>
<!-- analytics-code google analytics tracking code --><script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-55275551-1', 'auto');
	ga('send', 'pageview');

</script><!--  -->	<div style="display:none">
	</div>
<div id="reading-position-indicator"></div><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/aarn.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://aarn.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript' src='https://aarn.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202113.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.4',blog:'70528605',post:'16553',tz:'-4',srv:'aarn.com'} ]);
	_stq.push([ 'clickTrackerInit', '70528605', '16553' ]);
</script>
</body>
</html>